Investigating issues with Mews Kiosk

Incident Report for Mews

Resolved

We think the impact from the issue is over. Kiosk Customers can now perform operations on the Kiosk.
Posted Jun 17, 2025 - 17:21 CEST

Monitoring

The team has resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Jun 17, 2025 - 15:31 CEST

Investigating

We are currently investigating reports of an issue affecting the latest version of Mews Kiosk. Customers are currently unable to continue on the registration card. The team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Jun 17, 2025 - 15:02 CEST
This incident affected: Mews Guest Experience.