Downgraded Performance

Incident Report for Mews

Postmortem

Problem
On March 13 at 15:24 UTC, end-users experienced degraded performance across Mews products. The degraded performance status remained until 16:08 UTC.
Causes
The Mews Application received increased traffic, and we had issues auto-scaling our application to take the additional load.

Action
The problem was resolved by the Platform Team scaling out the infrastructure manually.

Solution
We have upgraded to more substantial hardware to enhance overall system performance. Additionally, the Mews platform team is currently identifying opportunities to improve our performance monitoring solution to reduce detection time.

Posted Apr 07, 2025 - 15:49 CEST

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Mar 13, 2025 - 17:31 CET

Monitoring

We can see the regression in performance has improved and continue to monitor the situation
Posted Mar 13, 2025 - 16:57 CET

Investigating

We have noticed a downgraded performance of the system.
We are currently looking into it.
Thank you for your patience.
Posted Mar 13, 2025 - 16:38 CET