Premium Chat Support - Service Disruption

Incident Report for Mews

Resolved

The issue has been resolved, and Premium Chat is now fully available to all Premium clients again.

Thank you for your patience and understanding - we look forward to assisting you!
— Mews Support Team
Posted Mar 19, 2025 - 12:07 CET

Identified

We've identified the issue and are currently working on a fix. Thank you for your understanding.
Posted Mar 19, 2025 - 11:42 CET

Investigating

We are currently experiencing an issue with our Premium Chat support functionality available to our Premium Support clients. This means that Premium clients may be unable to reach our support team via chat at this time.

We are investigating the issue right now, In the meantime, we encourage you to reach out via chatbot, email or phone for urgent matters.
We apologize for the inconvenience and appreciate your patience while this is being resolved.

We will provide further updates as soon as more information becomes available.
Thank you for your understanding.
— Mews Support Team
Posted Mar 18, 2025 - 14:45 CET
This incident affected: Operations.