System operational with potential power outage impact in some countries

Incident Report for Mews

Resolved

Power has been restored in most areas affected by the outage in Spain, Portugal, France, and Italy. Hence, we are resolving this incident. Our systems are operating smoothly.
Posted Apr 29, 2025 - 08:24 CEST

Identified

Our systems are currently functioning normally.
However, please be aware that due to a major power outage in Spain, Portugal, France and Italy there may be intermittent disruptions in those countries beyond our control.
Posted Apr 28, 2025 - 15:34 CEST