The issue is now fully resolved. Mews Guest Portal is now operating as expected.
Posted Jun 03, 2026 - 18:18 CEST
Monitoring
We've identified the issue and deployed a fix. Please refresh the page to restore the functionality.
Posted Jun 03, 2026 - 17:53 CEST
Investigating
We are currently investigating reports of an issue affecting Mews Guest Portal. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.