Incorrect tax rate applied to cancellation fees (Netherlands and Finland)

Incident Report for Mews

Resolved

The issue has been resolved for open reservations. Reservations that are already closed will require manual intervention.

Affected properties will be contacted shortly.
Posted Jan 12, 2026 - 18:27 CET

Monitoring

The team identified an issue that caused incorrect tax rates to be applied to cancellation taxes included in cancellation fees for some customers in the Netherlands and Finland.
The issue was triggered by tax rate changes effective January 1 and persisted until January 5 at 16:00:00 UTC.

We are correcting any impacted open reservations on our side.
For reservations that are already closed, affected customers will be contacted directly with the impacted reservations and clear instructions on the steps they need to take to resolve the issue.
Posted Jan 12, 2026 - 12:29 CET
This incident affected: Mews Operations.