Unplanned Outage - Cloudflare issues

Incident Report for Mews

Postmortem

Problem

On 2025-12-05 between 08:47 and 09:12 UTC Mews was affected by a global Cloudflare outage, rendering all our pages and APIs unreachable, returning Internal Service Errors. This resulted in Mews and all associated endpoints being inaccessible to customers for approximately 25 minutes.

Action

We began recovery efforts immediately while Cloudflare worked on a fix, even though this third-party outage was not entirely in our control. Potential impacts include:

  • Channel Manager or API Partners: connections to these services that do not have adequate retry/service interruption policies as per our guidance may be impacted. We have contacted affected partners with reprocessing guidance.
  • Background processing: may have been delayed. We made sure it caught up within minutes after our pages became reachable again.

Causes

The outage was caused by a widespread Cloudflare outage that affected multiple major sites, including Mews. Cloudflare is a leading internet infrastructure service that provides websites such as Mews with the ability to deliver their content more effectively and protects them from cyberattacks like DDoS by filtering out harmful traffic. It is one of the most relied upon providers for this type of services, as witnessed by other significant outages at the time too (LinkedIn, Spotify, Ikea, Sage, X).

Although incredibly rare, when Cloudflare experiences issues, it can impact the accessibility of websites and services that rely on its infrastructure.

Cloudflare provided their own public postmortem here: Cloudflare outage on December 5, 2025 .

Solutions

There are workarounds for this sort of issue, but they become a cost benefits analysis. Having a failsafe service akin to Cloudflare for issues would mitigate perhaps 50% of the impact an incident like this would have, but also would be so incredibly cost prohibitive as to have most business unable to operate profitably or to add significant complexity to the architectural setup. Typically the best solution in situations like this is strong liaison with the provider, and regular updates with our customers - it would be anticipated that an incident of this sort of magnitude would be a ‘once in 5 years’ type scenario.

 

We appreciate your understanding and patience during this incident, and we are committed to ensuring the reliability of our services moving forward.

Posted Dec 08, 2025 - 11:11 CET

Resolved

Our services were impacted earlier today due to a Cloudflare outage. Cloudflare has confirmed the issue was related to a change in their Web Application Firewall and has since resolved it. We will share more information as it becomes available today.
Posted Dec 05, 2025 - 11:33 CET

Update

The global Cloudflare outage is resolved and Mews is accessible again.
Reservations arriving through API and Channel Manager connections during the affected time window might be missing. Background processing and Connector API webhooks delivery might be delayed by 10-20 minutes as we are reattempting delivery to affected partners.
Posted Dec 05, 2025 - 10:45 CET

Monitoring

Cloudflare have reported the issue as mitigated and we are observing service recovery.
Posted Dec 05, 2025 - 10:15 CET

Update

More information on the cloudflare outage is shared on their official statuspage https://www.cloudflarestatus.com/incidents/lfrm31y6sw9q .
Posted Dec 05, 2025 - 10:04 CET

Investigating

We are currently experiencing an unplanned outage, one of our major cloud provision services (Cloudflare) is having a major incident, and it is preventing traffic reaching our Mews applications. We are working with them to remediate and will post updates regularly.
Posted Dec 05, 2025 - 09:59 CET
This incident affected: Mews Operations, Mews Guest Experience, Mews Business Intelligence, Mews Payments, Mews Open API, Mews Marketplace, Mews Events, and Mews POS.