Adding products to an open bill of a company profile results in an error

Incident Report for Mews

Postmortem

Problem

On 23rd of July, we experienced an issue with adding products to a bill for company profiles. We identified the root cases to be a faulty code change that was deployed few hours before incident was raised.

Action

After getting alerted we immediately spotted the faulty version of deployment and rolled back to previously stable version. Afterwards we were monitoring if there are any more enterprises running into same problem.

Causes

The issue was caused by faulty code change in add product dialog, which allowed calling specific API endpoint for company profiles, which wasn’t available for company profiles and started returning invalid responses.

Solutions

  • We are continuously improving our alerting and monitoring, as well as automatic testing measures to prevent user impact.
Posted Jul 31, 2025 - 10:54 CEST

Resolved

The issue is now fully resolved. Mews is now operating as expected.
Posted Jul 23, 2025 - 17:55 CEST

Monitoring

We have identified the issue and we have rolled out the fix. We are closely monitoring for any incoming errors. Customers are being advised to reload the page in case the issue persists.
Posted Jul 23, 2025 - 15:57 CEST

Identified

We have received reports regarding our users not being able to add products to open bills of companies. We have already identified the cause and are working promptly on delivering a fix.
Posted Jul 23, 2025 - 15:47 CEST
This incident affected: Mews Operations.