We have confirmed the full recovery of email delivery functionality and consider this issue resolved.
Posted Feb 23, 2025 - 17:42 CET
Monitoring
Our third-party email delivery provider has confirmed that functionality has been fully restored. We are actively monitoring the situation to ensure full recovery.
Thank you for your patience.
Posted Feb 23, 2025 - 16:36 CET
Identified
We are currently experiencing an issue with email delivery due to a problem with our third-party email delivery platform.
Our team has contacted them to resolve the issue, and we are awaiting their response. We will provide updates as soon as more information becomes available.
Thank you for your patience.
Posted Feb 23, 2025 - 15:42 CET
Investigating
We are investigating reports of login issues with Mews. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Feb 23, 2025 - 14:22 CET
This incident affected: Operations and Guest Journey.