Upsells in Booking Engine display all products

Incident Report for Mews

Monitoring

We've resolved the problem and are monitoring the situation.
Posted Apr 01, 2026 - 14:14 CEST

Identified

We identified issues inside Booking Engine where all products were displayed as available for Upsells. We're working on resolving the issue.
Posted Apr 01, 2026 - 14:13 CEST
This incident affects: Mews Guest Experience.