Payment and Reservation Issues

Incident Report for Mews

Postmortem

Problem

Customers, guests and channel managers are experiencing issues with processing online payments and sending reservations to Mews due to a communication failure with the payment gateway.

The errors first occurred on on 2025-01-20 01:01 UTC and the service was restored on 2025-01-20 02:23 UTC.

Action

We informed about the disruption on our public status page and also monitored the situation after the third party service was restored to ensure Mews systems was recovering.

Causes

The outages was caused by a planned maintenance window from one of our third party providers for payment processing. Mews failed to notify customers and partners about a the planned maintenance.

Solutions

Mews will adjust our process for planned outages announcement from third parties to make sure we can take mitigating actions or communicate the service disruption.

Posted Feb 03, 2025 - 16:42 CET

Resolved

All services have been fully restored and are operating normally. We apologize for any inconvenience caused during this incident.

Thank you for your patience.
Posted Jan 20, 2025 - 04:16 CET

Monitoring

Service performance is gradually improving. Card processing operations are being restored. We continue to monitor the situation.

We will provide a final update once all services are fully operational.
Posted Jan 20, 2025 - 03:55 CET

Update

We are currently experiencing service degradation affecting card processing due to third-party provider issues (PCI Proxy provider). Our team is in contact with the provider and working on resolution.

Besides payments, it's also affecting Reservations from Channel Managers.

We will update this status page once service is fully restored.
Posted Jan 20, 2025 - 03:34 CET

Investigating

We have noticed a downgraded performance of the system, affecting payments, and reservations. Our team is investigating the issue.

Thank you for your patience as we work to resolve this.
Posted Jan 20, 2025 - 03:03 CET
This incident affected: Operations and Payments.