Terminal Multicurrency payment issue (for properties with Multicurrency enabled)

Incident Report for Mews

Monitoring

We will continue to monitor the issue and advise when our payment provider expects to return to normal operation.
Posted Jul 11, 2025 - 16:16 CEST

Identified

Terminal payments that are eligible for Multicurrency are not offering guests the option to pay in their card’s currency. Instead, payments are being processed in the property’s default gateway currency.
The payment will still go through as normal, and online payments are not affected.
Our payment provider has identified the issue and is actively working on a fix. We’ll keep you updated as soon as it’s resolved.
Posted Jul 11, 2025 - 16:09 CEST
This incident affects: Mews Payments.