Investigating issues with French invoicing

Incident Report for Mews

Resolved

We have monitored the issued and it seems working properly again. No customers should be affected right now.
Posted Mar 26, 2025 - 11:12 CET

Monitoring

The team has resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Mar 26, 2025 - 10:56 CET

Investigating

We are currently investigating an issue with invoicing that is affecting French customers and preventing them from printing, sharing or emailing invoices.
Posted Mar 26, 2025 - 09:22 CET