Creation of payment requests fails

Incident Report for Mews

Resolved

The issue has been resolved. Payment requests should be working as expected. Thank you for your patience.
Posted Feb 12, 2026 - 20:25 CET

Monitoring

Deployment with the reverted changes has been deployed to production. Waiting for confirmation that the issue is resolved.
Posted Feb 12, 2026 - 18:24 CET

Update

We have identified the cause and are in the process of fixing it. We will update again once we have confirmation of a fix.
Posted Feb 12, 2026 - 16:58 CET

Investigating

We're investigating the issue.
Posted Feb 12, 2026 - 15:30 CET
This incident affected: Mews Payments.