Investigating issues with Mews Services (Messaging). We have received some reports from customers about being unable to access Messaging part and we are currently investigating it.

Incident Report for Mews

Resolved

We have fixed the issue on the Messaging area, it was an issue related to Avatars.

In case you are experiencing it, please refresh the page and it should be solved.
Posted Aug 04, 2025 - 17:13 CEST

Identified

We solved the issue on the Messaging part, if you are still experiencing it, please refresh the page and the issue shall be fixed
Posted Aug 04, 2025 - 17:10 CEST

Investigating

We are currently investigating reports of an issue affecting Mews. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Aug 04, 2025 - 16:34 CEST
This incident affected: Mews Operations and Mews Guest Experience.