Downgraded Performance

Incident Report for Mews

Resolved

The issue is now fully resolved. Mews is now operating as expected.
Posted Aug 05, 2025 - 14:13 CEST

Update

We have identified issues with our database and applied initial mitigation steps. We are continuing with investigating the root cause.
Posted Aug 05, 2025 - 13:52 CEST

Investigating

We have noticed a downgraded performance of the system.
We are currently looking into it.
Thank you for your patience.
Posted Aug 05, 2025 - 13:12 CEST
This incident affected: Mews Operations, Mews Guest Experience, and Mews Open API.