Global CyberSecurity Incident
Incident Report for Mews
Resolved
This incident had no impact on Mews services, and so will be marked as resolved now awareness has been raised.
Posted Jul 22, 2024 - 09:28 CEST
Monitoring
We are aware that a cybersecurity update has impacted IT systems and industries around the world. Currently there is no impact at Mews and our systems continue to run normally. We will continue to monitor the situation closely.
Posted Jul 19, 2024 - 13:27 CEST