Cannot update products
Incident Report for Mews
Resolved
We have identified the issue and rolled back to a previous version of our application that is verified to work.
Posted May 31, 2022 - 14:43 CEST
Investigating
We are currently investigating this issue.
Posted May 31, 2022 - 14:26 CEST
This incident affected: Operations.