Downgraded Performance

Incident Report for Mews

Update

The system continues to operate normally, and we are monitoring it closely. Some reports may occasionally load slowly or fail to load while we work on a permanent fix.
Posted Sep 25, 2026 - 16:53 CEST

Update

We have identified the source of the degraded performance and applied a mitigation that isolates it from the rest of the system. The system should now be responding normally. Some users may still experience slowness when generating the Manager Report. We continue to investigate and monitor the situation.
Posted Sep 25, 2026 - 16:13 CEST

Monitoring

We see that the performance of the platform across all connections is back to normal. We will keep monitoring the incident.
Posted Sep 25, 2026 - 14:10 CEST

Investigating

We have noticed a downgraded performance of the system.
We are currently looking into it.
Thank you for your patience.
Posted Sep 25, 2026 - 12:59 CEST
This incident affects: Mews Operations.