Downgraded Performance on Connector API

Incident Report for Mews

Postmortem

Problem

On August 25, 2025, a significant increase in timeouts occurred on the Connector API's restrictions/getAll endpoint. This was triggered by a sudden, unexpected increase in external traffic following a customer’s marketing campaign.

Action

We worked with the customer to reduce the impact on the system by temporarily reducing their rate limits. Additionally we took steps to limit the impact for other Connector API users by switching the reads in the operation to database replica.

Causes

The underlying cause was too strict usage quota on restrictions/getAll operation, causing repeated timeouts and subsequent cascade failure in external system.

Solutions

​We took steps to prevent the likelihood of similar issues in restrictions/getAll operation by reducing load on the primary database and increased usage quota.

For further planned improvements, we will be reviewing usage patterns and performance of restrictions/getAll operation. We also plan on providing Connector API users with better guidance in case of timeout errors and best practices for fault tolerance.

Posted Sep 08, 2025 - 12:11 CEST

Resolved

The issue is now fully resolved. Connector API is now operating as expected.
Posted Aug 25, 2025 - 13:46 CEST

Monitoring

We have resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Aug 25, 2025 - 12:19 CEST

Identified

We have noticed a downgraded performance on Connector API endpoint restrictions/getAll. We have identified the cause and working on a fix.
Posted Aug 25, 2025 - 12:06 CEST
This incident affected: Mews Open API.