The issue affecting Mews Analytics has been resolved. Performance has returned to normal, and all reports should now be accessible.
Posted Aug 18, 2025 - 15:25 CEST
Monitoring
We have seen recovery in Mews Analytics and the service is working as expected again. We are continuing to monitor the situation to ensure it remains stable.
Posted Aug 18, 2025 - 13:18 CEST
Investigating
We are aware of an issue where Mews Analytics is either not loading or responding very slowly. This affects multiple reports, including Manager Analytics, Aging Balance, and Deposit Ledger. Our team is actively investigating the root cause.
Posted Aug 18, 2025 - 11:40 CEST
This incident affected: Mews Business Intelligence.