We’re currently resolving all reservations impacted during the outage period. You may receive email as we work through the fixes.
Posted Sep 12, 2025 - 16:01 CEST
Update
All reservations created or modified between 10/09/2025 8:00am UTC and 11/09/2025 2:15pm UTC may have incorrect prices. We are currently working on a fix for those affected reservations. For a quicker solution, you can update the reservations manually
Posted Sep 11, 2025 - 16:53 CEST
Identified
We disabled the feature so new reservations should now have the correct tax.
Posted Sep 11, 2025 - 16:24 CEST
Investigating
We are investigating the cause of wrong behaviour of taxes