Employee privileges updates are not properly saved
Incident Report for Mews
Resolved
The issue is resolved. We apologize for any inconvenience it may have caused.
Posted Nov 14, 2022 - 16:27 CET
Identified
The issue has been identified and we are working on a fix
Posted Nov 14, 2022 - 14:51 CET
This incident affected: Operations.