Booking.com experience outage

Incident Report for Mews

Resolved

Booking.com outage is now resolved.
We are contacting Booking.com to get more details
Posted Jan 30, 2026 - 15:59 CET

Monitoring

Booking.com outage is resolved. We are confirming with Booking.com they are re-sending all affected reservations.
Posted Jan 30, 2026 - 15:42 CET

Investigating

We're investigating the issue.
Posted Jan 30, 2026 - 15:23 CET
This incident affected: Mews Marketplace.