BestWestern channel manager connection issues

Incident Report for Mews

Resolved

The connection is stable, and all previously failed items have been successfully retried.
Posted Jan 08, 2026 - 20:35 CET

Investigating

BestWestern is currently experiencing an unexpected database outage on their side. This issue is impacting reservation synchronization and inventory updates. We are monitoring the situation and will provide updates as more information becomes available.
Posted Jan 08, 2026 - 20:21 CET
This incident affected: Mews Marketplace.