Mews BI data was refreshed and the service now runs normally.
Posted Jan 23, 2026 - 00:04 CET
Investigating
We are currently investigating data delays affecting Mews BI. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible. The data is expected to be delayed by 4 hours.
Posted Jan 22, 2026 - 23:13 CET
This incident affected: Mews Business Intelligence.