Investigating currency issue with Mews Booking Engine

Incident Report for Mews

Resolved

The Mews Booking Engine was incorrectly using the users local currency rather than the configured currency. This has now been resolved.
Posted Apr 16, 2025 - 06:16 CEST

Investigating

We are currently investigating reports of an issue affecting Mews. The Mews team is actively working to identify the cause, and we will provide updates as soon as possible.
Posted Apr 16, 2025 - 04:38 CEST
This incident affected: Mews Guest Experience.