Search bar not working

Incident Report for Mews

Resolved

The issue has been resolved, no customers impacted.
Posted Aug 29, 2024 - 13:43 CEST

Update

Issue has been resolved, no customers were impacted.
Posted Aug 29, 2024 - 13:17 CEST

Investigating

There is an issue with the search bar, we are currently investigating the issue, and will provide an update soon.
Posted Aug 29, 2024 - 12:52 CEST