Downgraded Performance

Incident Report for Mews

Resolved

We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Sep 24, 2025 - 18:10 CEST

Update

During a new feature rollout we spotted some performance issues related to that feature. We've rolled it back and are monitoring this closely
Posted Sep 24, 2025 - 17:00 CEST

Monitoring

The team has resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Sep 24, 2025 - 16:44 CEST

Update

We observe elevated amount of timeouts on Connector API as well. We are continuing with investigation.
Posted Sep 24, 2025 - 16:37 CEST

Investigating

We have noticed a downgraded performance of the system.
We are currently looking into it.
Thank you for your patience.
Posted Sep 24, 2025 - 16:22 CEST
This incident affected: Mews Operations and Mews Open API.