Investigating issues with Mews Services

Incident Report for Mews

Resolved

Invoice printing for affected properties in Indonesia and Malaysia has been resolved. No further action is required.
Posted Apr 16, 2026 - 12:00 CEST

Monitoring

We have identified an issue affecting invoice printing for some properties in Indonesia and Malaysia. A fix has been deployed and we are monitoring for confirmation. We will provide a further update once resolved.
Posted Apr 14, 2026 - 18:23 CEST

Investigating

Investigating invoice printing issues in Indonesian and Malaysian properties for POS.
Posted Apr 14, 2026 - 10:17 CEST
This incident affected: Mews POS.