Failing payments, misssing reservations from channel managers

Incident Report for Mews

Resolved

An outage on our partner PCI Proxy’s side — has been resolved. We’ve recovered the missing reservations from Booking.com and will contact affected partners. If you’re still missing any reservations from this timeframe, please manually push them from your intranet to ensure proper delivery to Mews. We apologize for the inconvenience caused.

https://status.pci-proxy.com/incidents/f8bs962rwkkj
Posted Jun 23, 2025 - 10:23 CEST

Monitoring

PCI proxy confirmed services are back online. New reservations from channel managers are being created. Payments are being processed successfully.
Posted Jun 23, 2025 - 10:01 CEST

Identified

PCI proxy is experiencing outage thus new reservations from channel managers aren't created.
Posted Jun 23, 2025 - 09:45 CEST
This incident affected: Mews Payments and Mews Marketplace.