Mews BI Closed Beta has stalled data

Incident Report for Mews

Resolved

All data is refreshed.
Posted Aug 27, 2025 - 21:41 CEST

Update

We expect all data to be refreshed in one hour.
Posted Aug 27, 2025 - 20:38 CEST

Monitoring

We identified and fixed the root cause. The latest data is being loaded now.
Posted Aug 27, 2025 - 18:55 CEST

Investigating

After the planned Mews BI Closed Beta maintenance, we have issues with data updates. The reports do not show fresh data. We are actively investigating the root cause.
Posted Aug 27, 2025 - 18:00 CEST
This incident affected: Mews Business Intelligence.