An outage on our partner PCI Proxy’s side — has been resolved. We’ve recovered the missing reservations from Booking.com and will contact affected partners. If you’re still missing any reservations from this timeframe, please manually push them from your intranet to ensure proper delivery to Mews. We apologize for the inconvenience caused.
Posted Jul 05, 2025 - 10:37 CEST
Monitoring
PCI proxy confirmed services are back online. New reservations from channel managers are being created. Payments are being processed successfully.
Posted Jul 05, 2025 - 10:10 CEST
Update
We've spotted that something has gone wrong. We're currently investigating the issue, and will provide an update soon.
Posted Jul 05, 2025 - 10:01 CEST
Identified
PCI proxy is experiencing outage thus new reservations from channel managers aren't created and payments are failing.
Posted Jul 05, 2025 - 09:53 CEST
This incident affected: Mews Payments and Mews Marketplace.