Email issues
Incident Report for Mews
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 12:09 CEST
Update
A change was made to the links in our emails which has resolved this issue
Posted Sep 22, 2023 - 12:08 CEST
Update
We've discovered the issue is caused by some Microsoft email servers incorrectly identifying our emails as phishing, we're in communication with them to resolve the issue.
Posted Aug 30, 2023 - 10:01 CEST
Update
We are continuing to investigate the issue, and we have asked customers to get their IT teams to investigate at their end. We are currently waiting on feedback from these customers.
Posted Aug 14, 2023 - 10:49 CEST
Update
The issue seems to be affecting a small number of confirmation emails. We are continuing to investigate.
Posted Aug 09, 2023 - 16:22 CEST
Investigating
We are currently investigating this issue.
Posted Aug 09, 2023 - 15:12 CEST
This incident affected: Guest Journey.