Downgraded Performance

Incident Report for Mews

Resolved

The issue is now fully resolved. Mews is now operating as expected.
Posted Apr 27, 2025 - 12:13 CEST

Monitoring

The team has resolved the issue, and we are closely monitoring the system to ensure stability.
Posted Apr 27, 2025 - 11:45 CEST

Identified

We have noticed a downgraded performance of the system.
We are currently looking into it.
Thank you for your patience.
Posted Apr 27, 2025 - 11:31 CEST
This incident affected: Mews Operations, Mews Guest Experience, and Mews Payments.