Unable to Issue Invoice
Incident Report for Mews
Resolved
This incident has been resolved.
Posted Mar 06, 2024 - 04:57 CET
Monitoring
We have deployed a fix and we are currently confirming whether it has fixed the issue.
Posted Mar 06, 2024 - 04:40 CET
Update
We are still working on a fix, we expect to have the next update in 1 hour.
Posted Mar 06, 2024 - 03:31 CET
Identified
We have identified the issue and we are implementing a fix.
Posted Mar 06, 2024 - 02:55 CET
Investigating
We are currently investigating an issue with some of our customers not being able to generate invoices - getting error message "Oops, something went wrong". We will provide an update soon.
Posted Mar 06, 2024 - 02:32 CET
This incident affected: Operations.