Breaking changes in behavior of AvailabilityAdjustments
Incident Report for Mews
Resolved
After reverting the breaking changes and migration of affected data we didn't detect any further issues. The incident has been resolved.
Posted Mar 09, 2024 - 00:55 CET
Monitoring
We have successfully migrated the availability adjustments to maintain expected behavior and we will keep on monitoring the situation.

We recommend affected partners to check availability adjustments fetched between February 29th and March 8th, and perform full synchronization from February 29th. If you need assistance, please reach out to partnersuccess@mews.com
Posted Mar 08, 2024 - 20:34 CET
Update
We have reverted the behavior, newly created availability adjustments won't be affected.

We are working on migration of previously created availability adjustments.
Posted Mar 08, 2024 - 15:33 CET
Update
We are working on reverting the behavior and fix of the underlying data. Partners may need to refresh their data after we deploy a fix.
Posted Mar 08, 2024 - 14:33 CET
Identified
We have identified a breaking change in handling of Availability Adjustments which affects Connector API. Affected endpoints are availabilityAdjustments/getAll and availabilityBlocks/getAll (with extent for Adjustments enabled).

On these endpoints the Availability Adjustments created after February 29th, 9:42 UTC, were merged into larger blocks, causing unexpected change of behavior for partners.
Posted Mar 08, 2024 - 14:06 CET
This incident affected: Open API.