Failing payments, Reservation Delivery via channel managers

Incident Report for Mews

Resolved

Issue has been resolved.

Impact on Payments:
Temporary terminal unavailability.
Failing payments were reprocessed.

Impact on Marketplace
Reservation delivery delays.
Channel manager partners were notified to repush missing reservations.
Posted Jul 30, 2025 - 15:09 CEST

Update

Another minor outage window observed at 2:33UTC until 2:41UTC
Posted Jul 30, 2025 - 04:49 CEST

Update

Third-party partner has resolved the issue.

Affected period is 12:42UTC - 12:53UTC 30 July 2025

Payments and Marketplace fully operational.
Posted Jul 30, 2025 - 03:24 CEST

Monitoring

Third-party service disruption affecting Mews Payments and Marketplace

Payments:
Payment processing delays and terminals being temporarily unavailable.

Channel Managers:
Reservation delivery.
Delays and possibly missing reservations.
Posted Jul 30, 2025 - 03:15 CEST
This incident affected: Mews Payments and Mews Marketplace.