Inventory updates to Booking.com via our channel manager connections are currently delayed.

Incident Report for Mews

Resolved

The issue has been resolved. All systems are operating normally.
Posted Dec 10, 2025 - 18:13 CET

Monitoring

The delay in inventory updates is decreasing. We will continue monitoring the queue.
Posted Dec 10, 2025 - 18:00 CET

Investigating

Price, restriction, and availability updates to Booking.com via our channel manager connections are currently experiencing delays. We are actively investigating the issue and will share an update as soon as possible.
Posted Dec 10, 2025 - 16:54 CET
This incident affected: Mews Marketplace.