Kiosk showing white loading screen

Incident Report for Mews

Resolved

The issue is now fully resolved. Mews is now operating as expected.
Posted Jun 19, 2025 - 10:47 CEST

Update

The fix seems to have resolved some instances, however there continues to be instances showing a white loading screen, we are continuing to investigate
Posted Jun 18, 2025 - 18:51 CEST

Investigating

We've spotted that something has gone wrong with the latest version (4.25) of the Kiosk. We're currently investigating the issue, and will provide an update soon.
Posted Jun 18, 2025 - 14:15 CEST
This incident affected: Mews Guest Experience.