Experiencing 500 errors during login using the Mews mobile app
Incident Report for Mews
Postmortem

Problem

Mobile users encountered a 500 internal server error when attempting to log in to the Mews commander app.

Causes

A bug was introduced in a recent code change, affecting an endpoint used by the mobile commander app during login.

Solution

We added optional chaining in 2 places to cater for null values without throwing an error. This was tested on our development environment before being deployed to all environments.

We apologise for any inconvenience caused.

Posted Jan 09, 2024 - 16:09 CET

Resolved
We are no longer seeing any 500 errors in our metrics. So the issue is resolved. Apologies for the inconvenience
Posted Jan 04, 2024 - 16:16 CET
Monitoring
A fix has been deployed to all environments. The issue should be resolved - Will continue to monitor the situation for 30minutes
Posted Jan 04, 2024 - 15:43 CET
Identified
We have made a fix for the issue. We are currently deploying the fix to all environments and will provide an update soon.
Posted Jan 04, 2024 - 14:17 CET
Investigating
We have noticed elevated errors during login flows on mobile.
We are currently looking into this issue.
Thank you for your patience.
Posted Jan 04, 2024 - 13:07 CET