Some terminal payments are failing to process

Incident Report for Mews

Resolved

This incident has been resolved.
Posted May 18, 2025 - 20:04 CEST

Monitoring

Terminal payments are now processed correctly and are completed as expected.
Posted May 18, 2025 - 19:38 CEST

Identified

Some terminal payments are failing to process and are stuck in a pending state.
Posted May 18, 2025 - 19:03 CEST
This incident affected: Mews Payments.