BestWestern connection issues

Incident Report for Mews

Resolved

The failed items have been successfully retried, and the connection with BW is back to normal. Thank you for your patience.
Posted Dec 14, 2025 - 07:54 CET

Monitoring

Best Western connections have returned to normal. Monitoring is ongoing, and failed items are being retried.
Posted Dec 14, 2025 - 07:43 CET

Update

We have reached out to Best Western and are currently waiting for a response. In the meantime, the system is being monitored and recovery is being prepared for the failed items.
Posted Dec 14, 2025 - 07:27 CET

Investigating

BestWestern is experiences issues with inventory and reservation.
We are monitoring the situation.
Posted Dec 14, 2025 - 07:03 CET