Delayed delivery of emails due to 3rd party outage

Incident Report for Mews

Resolved

The issue is now fully resolved. Mews is now operating as expected.
Posted Apr 24, 2025 - 08:26 CEST

Monitoring

Delivery of emails is restored with minimum delay.
We are closely monitoring the system to ensure stability.
Posted Apr 24, 2025 - 01:30 CEST

Update

We have identified issues with all emails being sent from Mews, this appears to be caused by our 3rd party provider - SendGrid.

You can follow their status page for more updates https://status.sendgrid.com/
We are monitoring the situation closely.
Posted Apr 24, 2025 - 01:04 CEST

Identified

The Mews team identified the issue with 3rd party product outage. We are closely monitoring the situation.
Posted Apr 24, 2025 - 00:40 CEST
This incident affected: Mews Operations.