Properties in Germany are not able to issue invoices due to Fiskaly Maintenance

Incident Report for Mews

Resolved

We think the impact from the issue is over.
Posted Aug 24, 2025 - 20:09 CEST

Identified

Properties in Germany are not able to issue invoices due to Fiskaly Maintenance.
Fiskaly status pages
https://status.fiskaly.com/
https://v1.status.fiskaly.com/
Posted Aug 24, 2025 - 10:42 CEST
This incident affected: Mews POS.