The issue is now resolved. The latest version of Mews Kiosk application is fully functional.
Posted 10 days ago. Mar 20, 2025 - 21:04 CET
Monitoring
We have resolved the issue and we are closely monitoring the system to ensure stability.
Posted 11 days ago. Mar 20, 2025 - 18:37 CET
Identified
The issue is affecting the latest version of the Mews Kiosk application. Customers are advised to not update the application until the issue is resolved. Further updates will follow as we make progress.
Posted 11 days ago. Mar 20, 2025 - 17:24 CET
Investigating
We are currently investigating reports of failed payments affecting Mews Kiosk. We are actively working to identify the cause, and we will provide updates as soon as possible.
Posted 11 days ago. Mar 20, 2025 - 17:04 CET
This incident affected: Guest Journey and Open API.