System unavailable

Incident Report for Mews

Resolved

This incident has been resolved.
Posted Nov 01, 2021 - 12:28 CET

Investigating

We are currently investigating the issue of the system being unavailable.
Posted Nov 01, 2021 - 11:47 CET
This incident affected: Mews Operations, Mews Guest Experience, Mews Business Intelligence, Mews Payments, Mews Open API, and Mews Marketplace.