Downgraded Performance

Incident Report for Mews

Resolved

We have resolved the issue affecting some Swedish customers. The system is now operating as expected. Thank you for your patience.
Posted Apr 26, 2026 - 10:29 CEST

Investigating

We have noticed a downgraded performance of the system for some Swedish customers.
We are currently looking into it.
Thank you for your patience.
Posted Apr 26, 2026 - 10:09 CEST
This incident affected: Mews POS.