Issue with Mews Guest Portal

Incident Report for Mews

Resolved

Production and demo environments are confirmed to be working again.
Posted May 13, 2025 - 10:05 CEST

Update

Some customers were unable to access the guest portal due to an internal connection issue. This has been resolved and we have started to determine the cause. Production and demo environments have been confirmed as working fully again.
Posted May 13, 2025 - 10:01 CEST

Identified

The Mews team identified the issue with the Guest Portal and is working on a resolution. Further updates will follow as we make progress.
Posted May 13, 2025 - 09:47 CEST
This incident affected: Mews Guest Experience.