Online check-in journey not loading

Incident Report for Mews

Resolved

The impact of the issue is over.
Posted Mar 04, 2026 - 14:58 CET

Monitoring

The Online check-in is degraded mainly for the nationality step.
The issue was fixed and we are monitoring its impact.
Posted Mar 04, 2026 - 11:21 CET
This incident affected: Mews Guest Experience.